sabato, settembre 10, 2005

Firefox e Thunderbird 1.5

Windows Classic Theme on Firefox 1.5
E' uscita recentemente la versione 1.5 beta1 di Firefox. Gli sviluppatori hanno pensato di migliorare l'integrazione con Windows facendo in modo che i menu fossero coerenti con il "Luna Theme" di WindowsXP. Ma non hanno previsto la possibilita' di disattivare questa feature per gli utenti che invece usano il "Classic Theme", tra i quali il sottoscritto. Fortunatamente il tema di Firefox e' gestito via CSS e quindi per ripristinare la modalita' precedente basta aggiungere gli appositi parametri nel file userChrome.css contenuto nel profilo. Esistono anche estensioni per automatizzare l'operazione. Ecco l'articolo della KnowledgeBase.

Commento:
Sto provando le versioni 1.5 beta sia di Firefox che di Thunderbird, da notare che per il momento le versioni beta si identificano come 1.4 e non come 1.5.
Ci sono persone che non capiranno mai perche' complicarsi la vita usando software "alternativo" e persone come me che non potrebbero vivere senza. Quelli che usano da anni lo stesso browser, perche' e' il migliore, perche' e' quello che usano tutti, perche' non c'e' motivo per usarne un altro, perche' non sanno cos'e' un browser. E poi ci sono quelli come me, che trovano divertente l'innovazione e non e' mai abbastanza.
Comunque, veniamo al sodo.
Le versioni beta funzionano abbastanza bene, ci sono due differenze evidenti. La prima e' la diversa disposizione delle opzioni, la seconda il meccanismo di update che adesso e' molto piu' sofisticato. In pratica esistono dei "canali" (release, beta, nightly) dove l'update va a vedere se esiste un aggiornamento, se lo trova lo scarica e lo installa, con l'opzione auto e manuale. L'update non e' una intera installazione come in precedenza ma solo lo stretto necessario, l'applicazione viene quindi riavviata e il gioco e' fatto.
Le differenze meno evidenti riguardano alcune funzioni aggiuntive e il miglioramento della performance di alcune funzioni esistenti.
L'aspetto negativo e' che secondo tradizione i temi e le estensioni non funzionano piu' quando si cambia la versione. Fortunatamente le tre estensioni che uso io (adblock, validator, noscript) sono state gia' adattate. Anche alcuni temi sono stati portati.

Nessun commento:

Posta un commento